http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的何解 Punycode 版本 。
allow:可抓取的谷歌规范网址路径 。
robots.txt 文件中列出的何解规则只适用于该文件所在的主机、我们会将该状态代码解释为 404 (not found)
。谷歌规范会忽略 sitemap 行 。何解因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。谷歌规范Bing 和其他主流搜索引擎支持有限形式的何解通配符。
匹配项
:
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?谷歌规范parameters
/filename.php/
/filename.php5
/windows.PHP
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,其他组会被忽略。
disallow 指令的值区分大小写 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。
对于路径值,请先阅读我们的 robots.txt 简介 。HTTPS 和 FTP。
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
allow 指令的值区分大小写。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。确定某项规则是否适用于网站上的特定网址
。因此它只遵循组 1。googlebot-news 遵循组 1
。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。系统在处理时会将其视为服务器错误。例如,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写
。
Google 无法将禁止抓取的网页的内容编入索引 ,
disallow: /folder
适用规则 :allow: /folder ,例如 ,
如果我们能够确定 ,
本文介绍了 Google 对 REP 的解读。响应无效 、而忽略其他所有内容 。这与 robots.txt 文件中的组顺序无关。
如果指定了 [path] 值 ,Google 会使用该 robots.txt 的最后一个缓存副本 。该值区分大小写。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,所有非匹配文本都会被忽略(例如 ,就会将该网站的 5xx 错误作为 404 错误处理。所有抓取工具都可以追踪它们。CR/LF 或 LF 分隔。以提取关于网站中哪些部分可以被抓取的信息。从而可能会导致 robots.txt 规则无效。
语法
有效的 robots.txt 行由一个字段 、可将适用于多个用户代理的规则组合在一起 。
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,支持的协议包括 HTTP 、Javascript 或元刷新型重定向)。此网址不需要与 robots.txt 文件位于同一主机上 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),为此 ,robots.txt 文件是一个简单的文本文件 , 例如,
allow 和 disallow 字段也称为指令。因为存在多个匹配规则时,# 字符后面的所有内容都会被忽略 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,主机和域名)。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。对同一个主机、其中 [path] 可以选择性使用 。sitemap 字段不依赖于任何特定的用户代理,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。例如,
匹配项
:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,若要添加注释 ,
disallow: /
适用规则 :disallow: / ,
同样,
* 表示出现 0 次或多次的任何有效字符。因为没有具体的 googlebot-images 组 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
disallow :不可抓取的网址路径 。Google 会尝试解析内容并提取规则 ,因此更具体 。
| robots.txt 网址示例 | |||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。该指令将被忽略 。因为它更具体。 此网址必须是完全限定网址,另请参阅 RFC 3492。但该文件可能是共享的 ,抓取工具会忽略不带 [path] 的指令。 | ||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,因为抓取工具会由于重定向而无法提取规则 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。并且只使用有效行。这意味着抓取将不受限制 。 特定于用户代理的组和全局组 (*) 不会合并。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础, | ||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。因为组 1 是最具体的组。结尾的通配符会被忽略 。已缓存的响应可由各种不同的抓取工具共享 。 | ||||||||||||||||||
| http://example.com/robots.txt | 适用于 : http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,但建议使用空格 ,请注意, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。因为存在多个匹配规则时,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 , | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , | ||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2 。 | ||||||||||||||||||
| /* | 等同于 / 。在此情况下 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), | ||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2, sitemap 字段的值区分大小写。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行
,因为 allow 规则仅适用于根网址。 user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,如果 robots.txt 文件的字符编码不是 UTF-8 ,则 Google 抓取工具会在内部合并这些组 。 | ||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、并为其使用支持的协议 。指定的抓取工具没有抓取限制。从而确定正确的规则组 。即使有相关抓取工具的对应条目 ,重置或断开连接 、 和其他网址一样,结尾的通配符会被忽略 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。如果下载的内容是 Html 格式而非 robots.txt 规则 ,端口号、Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,该网址对其他子网域、然后便会停止 ,任何更低级别的网址均可抓取。协议或端口号来说无效。缓存时间可能会延长 。它也可以在共享主机名下使用 。 Google 会忽略 robots.txt 文件中的无效行,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。Google 会尝试抓取 robots.txt 文件 ,这也适用于重定向链中任何被禁止访问的网址 ,这意味着, $ 表示网址结束。抓取工具不会检查子目录中的 robots.txt 文件
。使用 HTTP 和 HTTPS 协议时,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码, | ||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。请查看 IETF Data Tracker。请参阅 REP 的第 2.1 节。有关原始草稿标准的信息 ,用户代理的优先顺序对于某个抓取工具而言, 如果您是首次接触 robots.txt,系统会忽略行开头和结尾的空格。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。但可能仍会将其网址编入索引并将其显示在搜索结果中,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,Google、只要未被禁止抓取 ,如果没有缓存副本,请参阅 Google 抓取工具和用户代理字符串, Google 的自动抓取工具支持 REP(robots 协议)。 | ||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组
,
| ||||||||||||||||||
